Deploying Ares Built App using Bootplate

Hi All,

This is a repeat question I posted earlier under newbie section but got no reply to. Maybe this is a more appropriate section to post it in.

With no Phonegap build support available for Webos, what do I need to do to use Bootplate?
I tried copying my assets, lib, sources and debug files and folders to bootplate and minifying and using palm package but although the app launches in the Touchpad, non of my buttons, date pickers respond to touches.

The same is true when I run the bootplate debug.

I am sure am missing something. I have not modified any of the files from the Ares folder.

I would appreciate it if someone could show me an alternative way of deploying an Ares built app to webos.



  • edited April 2014
    ok lets start here do you have a line like this in your index.html file

    if(window.PalmSystem) window.PalmSystem.stageReady()

    like this
    if(window.PalmSystem) window.PalmSystem.stageReady()	
    new App().renderInto(document.body);

  • What version of Ares/Enyo and webos are you talking about?
    I assume you want to know for Ares2 and some recent Enyo 2.4 version. And I assume you ask for HP webos 3.0.5
    I also want to understand more about using Ares2 for HP webos devices (TP, TP Go, Pre3, Pre2).
  • Hi microtech_mi and Martin,

    Thanks for your replies. To start with the answer to microtech_mi is yes. I have had an app developed in bootplate2.2 and have been deploying to touchpad and pre 3 with no problems.

    I have used a copy of the same bootplate2.2 app folder and only changed the app.js by copying what I have in Ares app.js and pasting it in the bootplate2.2 app.js. As I am only trying to develop a version of the bootplate2.2 in ares.

    Martin, I am using Ares2 version 0.2.11 and the enyo/onyx/layout version is 2.3.0-pre. 12. Basically I find ares2 code completion and error warning good for me. swapping between editor and designer as designer will not load with errors.

    The problem with the Ares 2 in bootplate2.2 is that it loads fine, but non of my ontap actions are effective. my datepicker just gets depressed and nothing happens. my popups do not show, though my filtering inputs work fine.

  • ok lets see if i can get my head around this.

    Dose your App run/work in Ares preview?
    Dose it work in Chrome browser on you desktop?
    If your button are working in chrome they should work on the touch pad! This sort of sound like a little debugging is needed. I think i going to need to see some code

  • Hi microtech_mi,

    The app runs fine in Ares preview and even the designer does not complain, and it also runs fine Safari browser. It is only when I copy the app code from ares into the Bootplate app.js that I start noticing the problem straight away. i.e running debug.html loads my app fine with all the user interfaces showing. I have noticed that the problem seems to affect things that have to popup like date pickers, menus and popups only.

    I shall try and see if I can extract some parts of the app code that fails as it is now a complete app and all I wanted to do was deploy it to my Touchpad and pre3.

Sign In or Register to comment.