Ares 0.2.9 is out

Happy New Year Ares2 users,

The latest version of Ares2 for 2013 is released!!

This release is still based on the 0.2.x line, still focused on the stability & usability of the IDE with again a special attention on Enyo Designer and PhoneGap Build.

This time you will also find small enhancements, like:
1. Enyo Inspector: to make possible the use a file chooser to define file path in for inspector src attribute
2. Enyo Inspector: a search field is added to filter-down the list of properties by name, for quickly finding a property
3. Node Server: the infinite recursion on server on Linux is fixed on Node archive operations
4. Ares uses http_proxy and https_proxy as environment variables
5. Support PhoneGap build for Windows Phone 8
... etc

As usual, upgrade your Ares 2 using:
npm update ares-ide

...or install it using:
npm install ares-ide

Top-level details are available from or


  • Having a weird issue on Windows.

    Going to create or open a project and selecting Home Directory results in a never-ending scroll in the command line window where I launched ares-ide.

    Tried running as administrator with the same result.
    Tried changing the @[email protected] in the ide.json as well.
    Also tried uninstalling/reinstalling

    I didn't use 0.2.7 extensively but definitely did not have this problem. This come up before?
  • Confirmed this on a second Windows 8.1 machine.

    Following information from both boxes.

    Windows 8.1
    Ares-ide 0.2.9
    Node 0.10.24

    The second box was a completely fresh install.

    Uninstalled 0.2.9 and installed 0.2.7 and the problem goes away on both boxes.

    I'll file a bug but wanted to follow up here as well.

  • I am running Windows XP and saw the same thing on 0.2.9 as well.
  • I filed a bug, but the problem was, at least for me, that you need to use rather than http://localhost:9009

    Didn't have the issue using
  • Hello pmarsh,

    Sorry for the last answer.
    These days, it is a busy period for the Ares team.

    Your issue is addressed by the JIRA ENYO-3634. The fix will be available in the next release of Ares, scheduled for end of January 2014.

    I let francoisconnetable who is in charge of ENYO-3634 continues this discussion if you need more information.
  • No worries, it's just as easy to use

    Thanks for following up, glad to hear you're busy hope it means lots more coming down the pipe soon!
  • Hey pmarsh,

    As marian has said, we were working on it. You'll be glad to know that the fix has been merged on git/master, so you have it now in Master :-)

    Let me know if it works for you, once you have a chance to test...
  • Just updated to 0.2.11 and it's working just fine on localhost as well as 127 thanks!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!