Can not create new files: Permission denied


I had no luck with ares till today. I tried version 0.17 again the last days and managed to get it installed and create a new project with bootplate 2.2. This actually did work for me the first time with ares, yeah. :)

Then I tried to import an existing project which was not created with ares but is based on some version of the bootplate, as well. This project never did show up in the project list. On the console the node.js part of ares produces a lot of output, but no error messages. That suddenly stops at some point and that's it. No project. Is there anything special I have to do with the project to be recognized by ares?

Then I tried to create a new file in the ares-created project and got the error "Permission denied" (I think it also included 403 somewhere). Huh? I reloaded ares multiple times, in some up to date version of Chrome and Firefox 18, also in IE once, but it never did create the file. My Windows-User has sufficient rights to the directory (and the parent directory). I created a file manually and that showed up in ares fine... hm. Also ares did copy the files into that directory by itself.. so what is wrong here?

Still can't use ares. :(


  • edited July 2013
    I will bet it did not have a project.json file did it. Its a little off ( i guess the best way to say) to import it has to have a project.json file. If it dose not have one use the create wich will add a project.json file too your package. As far as the 403 error you got me may be some one from the ares team will jump in

  • edited July 2013
    You can have more information from the service that handles your filesystem (hermes).

    In ide.json, there's a line with @[email protected]/hermes/fsLocal.js, you can change the value of --level parameter from http to info or verbose to get more details on the file operation.

  • edited July 2013
    Ok, thanks for the hint at verbose logging. I think the error is related to temp and home folder being on different partitions. I found a ticket for that already... this REALLY needs to be fixed. :(

    Actually I can't find a project.json in my ares test project, the one which ares displays nicely, either. Might be related, too? I often get 403 error messages out of nowhere.. ;)

    Edit: Strange... I now moved my windows temp directory to the same drive, but ares still uses the old temp directory. Why that? Does it save that somewhere?
  • Ok, something still saved the old temp directory... after a full reboot it now runs with temp directory on the same drive and my problems are gone. Also there is now a project.json in my ares-test project.

    I copied & modified that project.json to my other project and could now import it fine, too.

    Yeah. :)
    Thanks for your hints.
  • @Garfonso wrote:
    "I think the error is related to temp and home folder being on different partitions."
    For what platform (Windows, Linux ...) is this a problem ?
    Any pointer to the related ticket please ?
  • I've seen this issue on Linux. Garfonso has seen it on Windows.

    The related ticket is

    All the best
Sign In or Register to comment.