Designer Button Greyed Out?

My apologies in advance for what I'm sure is a very simple, newbie question. However, my goggling and research on the forums has led me nowhere and I'm new enough to enyo development/ares that I don't know how to procede.

How can I get the "Designer" button to be un-greyed out when editing a file? That is, I've installed ares via NPM, and have it up and running in a browser. However, if I create a new file, and use the "Add Kind" button, I see the following

That is, there are four buttons up top, and the rightmost button is the "Designer" button. However, this button is greyed out and un-clickable. I assume there's some magic component I need to add to tell ares "Hey, I need the designer", but I don't know what that is. Also, along similar lines, is there a basic "getting started with ares" document anywhere that answers these sorts of questions?

I've included my js file below for reference.

name : "MyAppName",
kind : "Control",
components : []


  • From the image it appears you are not on the latest Ares 0.1.6 version. I tried your example on that newest version and it enables the Designer.
    And perhaps you some other additional code in the file too ? some global function definition or similar?
    The latest Ares version checks for a number of error conditions when you click the Designer button.
  • Martin — thanks for the data point. It inspired me to poke around for a bit and I was able to solve my problem by starting a new project from a bootplate template. The previous file I listed above hadn't done this (I had created an empty template). I'm still not sure what the magic bits are that control the display of that design button, but I have enough now to tinker.

    Thanks again for the attention!
  • @alanstorm - you are welcome.
    Are you on Ares 0.1.6 version ?
    Perhaps older versions did disable the Designer button and now you will get specific error message in such case (which is more helpful).
  • i have found that happen's when a package.js file i missing! Watch the node ide window (cmd line) you see a 404 cant find file ?????

  • @Martin — I'm pretty sure I'm running 0.1.6 — I installed the latest version from NPM, and those numbers were included in the npm console output. Where in the UI are these error messages supposed to show up?
  • @microtech_mi The console is complaining about that missing file

    ares http home GET /files/file/Dropbox/ares/enyo/source/package.js? 404 0ms - 74b
    Lacking other information, I'm going to assume ares expects your project to be organized in a certain way if you're going to use the designer.
  • frist browse to there and see if it there. If it there then some reason ares not finding it. ( then we need to tell the ares crew about) If it not there grab a copy of the file of git hub and see if that fix it

    Yes it it organized in a certain way
  • @alanstorm wrote:
    > Where in the UI are these error messages supposed to show up?
    Errors are displayed in a error dialog window in Ares 0.1.6 version. They might be in the logfile (console output) too.
Sign In or Register to comment.