Problems with minify after new installation


I had to do a clean new install of my laptop (Ubuntu 13.04 64-bit). I did clone my apps from github and wanted to start working on them again. I did a "./tools/" from within my apps main flder as usual and only get a

"enyo/tools/ args: "

as result. Nothing else! What am I doing wrong? Did I forget to install something on my fresh Ubuntu installation?

Thanks for your advice!



  • Ok, my "/bin/sh" ws a symlink to "dash".
    "dpkg-reconfigure dash" to change it to "bash" didn't help either :(

    Any further ideas?
  • In three variables are set. Check their values (add "echo $<VAR>" statements to the script) and see if they are sensible or garbage.

    And check if node is installed correctly.
  • /home/marcel/Dropbox/webOS-Apps/Enyo2/tt-rssenyo/tools
    The TOOLS variable is ok. But will the others work with the "/../" in the link? "enyo" folder is in the same folder as "tools".

    If I set them manually it doesn't work either:
    enyo/tools/ args:
  • Yes, this output is from if a "node" executable is found but the scripts fail.

    Looking at, the default node.js in 13.04 is 0.6.19 which is pretty old. I think we need 0.8 for minify now, so try updating from the site.
  • I tried 0.10.12 and 0.8.24 with the same results :( Any other idea?
  • I did uninstall node, nodejs,.. and reinstall nodejs 0.6.19. Now it works again :) FINALLY
  • @linuxq - Marcel - there was havy work going on to make next version 0.2.2 Ares run with newer node version Node.js 0.10.x:
  • I'm surprised 0.8.24 failed... I'm running 0.10.15 on my Windows machine and am able to run the minify and deploy scripts.
Sign In or Register to comment.