Ares 0.1.2 is out (Sprint 11)

Although not yet ready for prime-time, we are hopefully getting closer & closer...

- npm install ares-ide

- Ares now automatically manages the content of the "package.js" file, so that you do not have to bother about it when creating/deleting/renaming/moving/copying files & folders.
- We started to document how to create new Ares plugins

- When creating a new project using the _Bootplate Nightly_ template, the Ares Designer does not work. Prefer creating new projects with _Bootplate 2.2_ a list of bug-fixes (such as the restored ability to use PhoneGap Build service for a non-Enyo-based application)

Please report issues (possibly with the "ide.log" generated by the "-L" option) using our JIRA at (use the "ares" component). We usually escalate quickly the community-reported issues so that they can get fixed within the next sprint.


  • edited April 2013
    Thanks @fix_kowalski and team !!!
    I upgraded to this 0.1.2 version and it is getting better for me - running Win7 x64.
    I was able to build a app package within phonegap. :)
    I was able to install the app on TouchPad and on Pre3 devices.
    But so far this app (even a fresh bootplate 2.2.0 app) does not run on my webos devices. An webos app card is opened and the centered icon flashes for ever.
    I did not try other devices and also I did not inspect details of the issue.

    For newcomers (like me) is might be important to know that
    + with the free phonegap build service you can build only one app (use only one app id).
    => If you try to build additional ones you will see a warning in the Ares logfile.

    + You need to go to the phonegap site to see / download your newly build app.
    => in order to get to the phonegap site - you either have to know the URL or in Ares you go to Ares menu "Account" and click on the lower right area where the details are presented. The click opens the phonegap window.

    + the phonegap app output is available for download from the phonegap site for the specific platform(s).
    => I did not see a mechanism to upload the results directly onto your development system.

  • We indeed have short-term plans to (1) complete the PhoneGap Build related documentation and (2) add more code to handle the download phase. Thanks for reporting that the PGB generated app does not work on webOS devices. Do you see this as a PGB issue or as an Ares2 issue?
  • not really sure how to debug my problem:
    Now I followed some of the instructions - not sure if all of the blog post applies for Ares too:

    I addded this one line to my App.js
    		{kind: "Signals", ondeviceready: "deviceready"}
    and at the index.html I added this cordova line before the enyo.js line:
    I rebuild the "Hello World" demo app from the bootplate-2.2.0 - but still the same result on my TouchPad. I get a 7MB big app file and I installed it with preware app. I used to get a smaller app file size of 250kb before I once enable some debug option for PhoneGap build. Not sure how to undo this.

    Was anyone succesful in building a webos demo app that was created in Ares 0.1.2 and that runs on TouchPad then?
  • I haven't done it with Ares but I have gotten one running on the Touchpad. The blog post isn't clear about the index.html file and executing the kind in the device ready function. In my experience you have to add a
    enyo.dispatcher.listen(document, "deviceready");
    document.addEventListener("deviceready", onDeviceReady, false);
  • Updated to 0.1.2 myself. Updated ok using git and instructions except when trying to follow the ares-ide.cmd that didn't seem to exist. I could get to work using 'node ide.js' like before...
  • @strider73 Thanks!
    But it did not yet work out for me. Still the same behaviour on the TouchPad.
    I used your first alternative and I modified the App.js to be like this:

    name: "App",
    kind: "FittableRows",
    fit: true,

    {kind: "onyx.Toolbar", content: "Hello World"},
    {kind: "enyo.Scroller", fit: true, components: [
    {name: "main", classes: "nice-padding", allowHtml: true}
    {kind: "onyx.Toolbar", components: [
    {kind: "onyx.Button", content: "Tap me", ontap: "helloWorldTap"}
    {kind: "Signals", onDeviceReady: "deviceready"}
    helloWorldTap: function(inSender, inEvent) {
    this.$.main.addContent("The button was tapped.
    enyo.dispatcher.listen(document, "deviceready");
    I'm still missing something.

    Please note that I now put "onDeviceReady" instead of "ondeviceready".
    Should that matter ??
    .. still waiting for my first phoneGap app running on TouchPad ..
  • This is the main part to my index.html file for the touchpad app:
    			 enyo.dispatcher.listen(document, "deviceready");
  • edited April 2013
    @strider73 - thanks again !
    I tried to apply your additions to what the bootplate-2.2.0 template looks like (I have used Ares 0.1.2 to create this simple "Hello world" app project.)
    Again no success - still the same behaviour.

    This is the new main part to my index.html file for the touchpad app:

    ... if (!window.App) { alert('No application build found, redirecting to debug.html.'); location = 'debug.html'; } enyo.dispatcher.listen(document, "deviceready"); new App().renderInto(document.body);
  • Hmm. Can you debug ? Are you getting any errors?
  • @strider73
    hmm - where/how to debug ? you mean debug on the TouchPad to find out why the app is not launching .. ? I have no idea how to debug that ..
    With Ares1 I was able to push the app to the device and then even use the build in debugger from Ares to inspect details on the device via the USB connection.
    Can I use a similar approach for Enyo2/phoneGap app from Ares2 ?? (I'd love too).
    I think it would already help me a lot to see (perhaps a video) of an example app that is defined in Ares2 and that is finally executed on a webos device.

    I assume I'm missing only a small piece - but I have no idea where to start with troubleshooting.
  • On TouchPad, the usual way is to use the developer shell (novaterm or ssh) to stop WebAppMgr and start it again with the console routed to the shell so you can see error messages from WebKit.
  • edited April 2013
    I read the "Cordova webOS Instructions:" again:
    - Set up your project the same way you would set up any other bootplate project.
    I assume Ares takes care of this when I create a new bootplate-2.2.0 project.
    I did not do anything in addition.
    - Modify your index.html and JavaScript files as outlined in this blog post: [JavaScript Apps for Open webOS With Enyo and Cordova](
    I tried to do some of the steps that might apply to Ares.
    - Copy appinfo.json from the PhoneGap 'lib/webos/framework' directory and a cordova JavaScript file from the PhoneGap 'lib/webos/lib' directory
    No, I have not done this. I have no idea where to find such PhoneGap 'lib/webos/framework' directory. On my Win7 computer I do not see such "webos" directory:
     Directory of C:\Users\xxx\node_modules\ares-ide\lib
    [.]      [..]     [extra]  [foss]   [g11n]   [layout] [onyx]
    - Modify appinfo.json for your project and add an icon
    No, I have not done this, I have no such file. At the phonegap webpage I selected a icon image file - but it does not display on the TouchPad at all.
    - run tools\deploy.bat --cordova-webos or tools/ --cordova-webos to deploy your app.
    No, I have not done this, I have no such tools directory in C:\Users\xxx\node_modules\ares-ide
  • edited April 2013
    @Ben thanks.
      On TouchPad, the usual way is to use the developer shell
    So - I should have the dev- enviroment for TouchPad 3.0.5 installed and use that for debugging a connected device .. (I guess I need to read/learn more about that and then I hope to find some time next few days.)
    The device deployment and debugger was so nicely integrated with Ares1. :)
    Well - I understand that Ares2 can not be so complete at this time.
  • Actually you can use ares1 to debug if you connect it up still. the messages still come across even if you can't edit the code.
  • Did you download cordova, unzip and go through the lib folder in the cordova folder? If it's not in 2.5,

    On cordova try version 2.2 to get the file from the webos/framework.

    You need an appinfo.json file to run on touchpad. This would look like any enyo1 appinfo file that would work on the touchpad.

    I used the packaging tool that comes with the HP Webos SDK rather than deploy.bat. This worked fine.
  • @strider73 - thanks again for giving even more hints !

    No - I have not downloaded any Cordova bits - as far as I know. Just consider that I know nothing about Cordova (it is kind of black box - and I'm even not sure what it is supposed to come out of that black box).
    I think I'm using the online PhoneGap tools and I even managed to get some valid build token. I can connect to the phonegap build website and I copy over my single app id from the website to my Ares2 project configuration. I see that remote builds are get running for my app. On the website I configure Cordova 2.5 as that is the highest number for my free account. Once the build is done I see that I can download some app.ipk file (~7 MB).

    In my project I can not find any appinfo.json file. At what folder should this file be located?
  • It should be in the root folder of your app. My guess is ares 2 doesn't create this automatically.
Sign In or Register to comment.