Deploy CSS url issue

When I download a zip of bootplate and run the deploy script, on a mac, the URLs for images in css don't work correctly. It breaks Onyx's background images because it's trying to load a weird path that is partially the location of bootplate on my system. I'm not sure why this would be happening. Any ideas?


  • I've had this problem in ares (at least the last time I checked). Loader.js is probably the key and the $lib variable.
  • I figured out what was happening. When I opened up the path in the terminal I typed the path in lower-case thinking nothing of it. When it deployed, node checked the path, which was lowercase, against the system path, which was partially uppercase. As a result, it messed some of the paths up.
  • I having a very similar issue, but don't see any case issues in my path/terminal command. Can you elaborate on the path issue and how you resolved it?
  • Tried using the deploy script tonight and noticed some CSS path issues. Seems to be worse when @importing .less files. In my case, Theme.less imports App.less which imports a couple others. Images referenced by those final files have source/ prepended 4 times before the right path. Find/Replace all the source/ from app.css fixed it but not ideal.
  • follow up ... was able to get the deploy script working without changing the source but had to specify the package and source directories on the command line:

    tools\deploy -p source\package.js -s .
  • I've got the same issue as @tpaustin, my paths in the minified css file were wrong (prefixed with a "source/" ). Thanks to @theryanjduffy i got it to work properly.

    tools\deploy -h shows the package.js in the root path as default value, containing the following code with a message to not edit the file, to keep the paths correct for the minification process (using bootplate):


    Well obviously, it causes an error, but i'm still curious why.
  • I've got this issue and then I tried the solution given by @theryanjduffy, but it's not working.

    I have a fonts folder that I've added in the deploy.json, in the assets array. I have a css that refers to a font located in this folder, and when I deploy the app the css code is changed, a "/source" is prepended in the URLs, such like @Riplexus described.

    Can someone help me?
  • GabrielSOD, I'm not seeing that issue.

    I cloned Bootplate, created a fonts folder off the project root and put a font in it.

    I added the fonts folder to the assets array in deploy.json
    	"enyo": "./enyo",
    	"packagejs": "./package.js",
    	"assets": ["./icon.png", "./index.html", "./assets", "./fonts"],
    	"libs": ["./lib/onyx", "./lib/layout"]
    I also added my font to main.less
    @font-face {
      font-family: firepowerbb;
      src: url('../../fonts/FirepowerBB.ttf');
    .firepower {
      font-family: firepowerbb;
    I added the .firepower CSS class to the "main" component in the scroller.

    Both the deployed index.html and the undeployed debug.html have the correct path to the font and display it correctly when I run the app. Can you provide the the relevant parts of the source code you're using?
Sign In or Register to comment.