Textboxes not working on Android Jelly Bean

When I run the app on a Jelly Bean device or emulator, it won't let you insert any text on the textboxes. I tried removing the InputDecorator to see if it was the problem, but no luck. The controls get the focus but when you type, no text is written. Also, I checked if the actual value of the TextBox is changed, but no.

For reference, I'm using an HTC One S with a AOKP JB 4.1 ROM and also the JB Stock Android Emulator. It works fine on Android 2.3.3 and Android 4.0.3 emulators and Android <4.1 devices.


  • Anyone having the same problem? Anyone propose a solution?
  • Are you using a RichText control? Those have some real problems on Android due to how they use the IME system where you see underlines, but no text until a word is completed. This isn't a Enyo problem directly, but an issue with divs marked contentEditable.

    I've been testing a bit with a Nexus 7 running Jelly Bean; is this something you can reproduce with the sampler app? Are you building for browser or PhoneGap?
  • Using onyx.TextBox. I'm building for PhoneGap (cordova 1.9). I'm gonna try with the sampler to see if the problem is in my code.
  • FIXED! I updated to PhoneGap 2.1.0 and the problem is gone.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!