Enyo 1.0 website, sliding panes and virtualList not working on pre2 and iphone 4

edited June 2012 in Enyo 1.0
I have a website built with enyo 1.0. Opening the site on the pre 2 or the iphone 4 it does not work. On the pre 2 the app loads fine, but when I try to scroll the entire page moves around. On the iphone 4 the app does not ever finish loading. Any ideas?

Comments

  • Enyo 1 was never really intended for use on web sites, just for on-device apps. The Pre2's browser doesn't implement the touch events that are used by the framework, but they are available for on-device apps. No idea about the iPhone 4 -- what iOS version is on it?
  • I see. I was surprised that the apps work on device and not on the browser for the Pre 2 since apps are also websites. I believe the iPhone has iOS 5
  • I haven't had a chance to test yet but does the Touchpad browser support the touch events needed by the framework?
  • The TouchPad should in 3.0.4 and later.

    Events in the browser in webOS are a bit complicated because the browser is a web app with a second instance of WebKit running through a object-tag event proxy system.
  • It for sure works in 3.0.5. Enyo 2 of course also has the same problems on Pre. Weirdly, scrollers don't seem to finger-scroll on Pre, though flick scrolling works.

  • It for sure works in 3.0.5. Enyo 2 of course also has the same problems on Pre. Weirdly, scrollers don't seem to finger-scroll on Pre, though flick scrolling works.


    ... I started typing this a day or so ago on my TouchPad, and was never able to Post it. Not sure if I was having network difficulties, or if posting doesn't work on TouchPad.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!