Control:createComponent not functioning like previous versions

In previous enyo versions I was able to specify {owner:someOtherOwner} as the second argument when calling createComponent ( ) = "newComponentName"; this.$.aComponent.createComponent(newComponent,{owner:someOtherOwner});
Then someOtherOwner.$.MyComponentName would be available. Now, that doesn't seem to be working at all.

I have also tried = "newComponentName"; someOtherOwner.$[] = this.$.aComponent.createComponent(newComponent,{owner:someOtherOwner});
However the return value seems to be an actual img object (newComponent is an enyo/Image) and not the enyo object.

Is there a way that I can get this to work in 2.7?


  • Solved this one!

    my require had a typo!

    var Imgae = require('enyo/Image');

    Then when I set the kind


    It was somehow creating a DOM Image even though I never defined Image!

    I figured this out by passing a div instead of an image, and it was working correctly, which made me dig deeper into what was wrong with the Image kind. The answer, my stupidity!
Sign In or Register to comment.