install of enyo-dev

edited May 2016 in Enyo 2.7
Get the following error with Node v6.2.0 and NPM v3.8.9 installed and using sudo npm install -g enyo-dev.
Any thoughts how to overcome?

> [email protected] postinstall /usr/local/lib/node_modules/enyo-dev > node ./bin/upgrade.js fs.js:634 return binding.open(pathModule._makeLong(path), stringToFlags(flags), mode); ^ Error: EACCES: permission denied, open '/Users/username/.babel.json' at Error (native) at Object.fs.openSync (fs.js:634:18) at Object.fs.writeFileSync (fs.js:1327:33) at save (/usr/local/lib/node_modules/enyo-dev/node_modules/babel-register/lib/cache.js:57:40) at _combinedTickCallback (internal/process/next_tick.js:67:7) at process._tickCallback (internal/process/next_tick.js:98:9) at Function.Module.runMain (module.js:577:11) at startup (node.js:160:18) at node.js:449:3 /usr/local/lib └── (empty) npm ERR! Darwin 15.5.0 npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "enyo-dev" npm ERR! node v6.2.0 npm ERR! npm v3.8.9 npm ERR! code ELIFECYCLE npm ERR! [email protected] postinstall: `node ./bin/upgrade.js` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the [email protected] postinstall script 'node ./bin/upgrade.js'. npm ERR! Make sure you have the latest version of node.js and npm installed. npm ERR! If you do, this is most likely a problem with the enyo-dev package, npm ERR! not with npm itself. npm ERR! Tell the author that this fails on your system: npm ERR! node ./bin/upgrade.js npm ERR! You can get information on how to open an issue for this project with: npm ERR! npm bugs enyo-dev npm ERR! Or if that isn't available, you can get their info via: npm ERR! npm owner ls enyo-dev npm ERR! There is likely additional logging output above. npm ERR! Please include the following file with any support request: npm ERR! /Users/psarin/WebStormProjects/npm-debug.log npm ERR! code 1

Comments

Sign In or Register to comment.