Enyo 2.7.0 Release Candidate

We've made good progress getting Enyo ready for release. We're at the point now where we have tagged a release candidate so we have a marker in the sand. The release candidate allows us to begin our internal testing.

If you are interested in checking out this version of Enyo, you can use the 2.7.0-rc.1 tag. To use this with "enyo init" you can update your .enyoconfig file as follows:
  "targets": {
    "enyo": "2.7.0-rc.1",
    "layout": "2.7.0-rc.1",
    "canvas": "2.7.0-rc.1",
    "svg": "2.7.0-rc.1",
    "moonstone": "2.7.0-rc.1",
    "onyx": "2.7.0-rc.1",
    "spotlight": "2.7.0-rc.1",
    "enyo-webos": "2.7.0-rc.1",
    "enyo-ilib": "2.7.0-rc.1"
There will certainly be more changes before the official 2.7.0 release.

We are also nearing the 1.0.0 release of the enyo-dev tool. If you would like to start using this tool, you'll need to check out the master branch directly from github. This version requires node version 4 or higher.

See the earlier announcement for more information.


  • Exciting news - Congratulations!
    I have a question (being a node beginner), unfortunately I setup enyo-dev yesterday - a few hours before JayCanuck updated the CHANGES.md so I bumped my Windows node install to stable 5.7 since >= 5 was required. Is it reasonably safe to stay at 5.7 or recommended to go back to 4.3.1 LTS now that 5 is no longer required?
  • You should be fine on 5. I'm using 5.4 right now.
  • Thanks, sorry to bother again, but am I right in thinking that the Palm SDK tools are java based, so I shouldn't have any conflicts there?
  • I was slowly making progress with the old 0.5.x enyo-dev, but I'm stumbling a bit with 1.0.0...
    If I add all the libraries listed above with the 2.7.0-rc.1 tag, enyo init immediately returns with WARN enyo-dev/init: Failed to initialize the template without fetching the libraries. So I started adding the libraries I wanted one by one to see where it would fail (I already knew enyo was getting cloned). Here's how it worked for me:
    • enyo - cool
    • layout - cool
    • onyx - cool
    • enyo-webos - cool
    • enyo-ilib - FAIL

  • I see this issue if I remove the enyo-ilib declaration from the "sources" property in .enyoconfig. Did you add enyo-ilib to both libraries and sources?
  • libraries, sources and targets and I feel I've triple-checked for typos. I just tried it with only enyo and enyo-ilib with the same response
  • Dang - finally found a missing quote - My Bad, Sorry!
Sign In or Register to comment.