enyo-ilib not working

edited May 2014 in General

I'm using bootplate with enyo-ilib, and I'm trying to translate strings in my app using the $L function, but it's not working, the strings still the same in the app. I'm brazilian, so the returned Locale when I call ilib.getLocale is pt-BR, so the translation should work by creating a pt folder with a strings.json file, but it's not.

I've created the folder resources in the assets folder and put language folders, such like pt, fr, and so on, each one containing a strings.json file. I've tried to put the language folders in the root of the project, and in the assets folder too, but it's still not working.

Can someone help me?
Thank you, in advance.


  • By default, ilib uses a resources folder at the root of your project (rather than inside assets).

    To support this, you need to add this resources folder to the "assets" item in deploy.json. For example "assets": ["./index.html", "./assets", "./resources", "./manifest.webapp"],
  • It's still not working.
  • Use the Network debugging panel in your preferred browser, and observe what files it's trying to load.
Sign In or Register to comment.