Latest Sampler on Legacy webOS (1/19/2014)

Platform = Pre2 running webOS 2.2.4 Browser:
I noticed yesterday that no longer shows a down state when Buttons are pressed. I can go to the fiddle and see the handler is fired, but there is no UI feedback. The Enyo Core/UI Buttons do show the down state as do the old Onyx buttons at Onyx/Basic Buttons.
The Latest Onyx button feedback still fires on webOS 3.0.5 (Touchpad), but scrolling the Sampler's left-pane lists no longer works on 3.0.5. Scrolling those panes never worked on 2.2.4, but it does work on 3.0.5 running the non-latest sampler.
I think legacy webOS is at the bottom of support priorities, but I'd love to see it inch up rather than down as I'm hoping to work with 2.3 for legacy once its released.


  • If you can figure out why this has changes, we'll gladly consider a patch. I personally don't have any 2.2.x devices charged up and in use anymore, although I do keep a TouchPad up and running for some debugging work.
  • Thanks Ben,
    I wish I were in a position to provide that contribution, but beyond the fact that I haven't been a serious coder in over 10 years, I just don't have the time. Luckily the issue that worries me the most is the behavior in 3.0.5 and maybe if I ask with a pretty-please you'd take a peek at that :)
    On closer inspection, scrolling still works, but for both scrolling the Sampler's left-pane and making selections in those panes, the first touch is ignored. Once a panel is 'activated' behavior seems familiar...
  • I just discovered that this 'first touch is ignored' behavior is also found in Firefox 26 on Ubuntu 12.04 32bit and Chrome 31 on Windows7 64bit. Only for latest sampler, the regular sampler doesn't have this behavior. So I guess I jumped the gun assuming this was a webOS problem...
  • I can confirm the problem with needing two taps to select an item in the list in sampler... will investigate this morning.
  • Thanks again... this ended up being a pretty nasty bug with some new mechanisms we had just added for better detecting the showing state of controls that interacted badly with popups. We just pushed a fix into the enyo repo for this.
  • Hi Ben, You're too kind with the thanks. I'm just poking at stuff and the Enyo team is doing all the work! I just checked 'latest' on my Pre2 and the first touch is no longer ignored. I was hoping the fix for that might also address the Onyx basic button state feedback for webOS 2.2.4, but that remains broken... It works for button groups, but there is still no UI feedback for ungrouped Onyx buttons on webOS 2.2.4 (although toggles work, but I imagine that's a group 'under the hood').
    Thanks for that big fix though!
Sign In or Register to comment.