TimePicker - Enyo2 Sampler


I built a TimePicker in my app, just like the sampler. The Mode "is24HrMode" is not working in my App and also when I start the sampler in jsfiddle http://jsfiddle.net/bert2000/CJdVb/
I've also tried to set with "this.$.mytimePicker.setIs24HrMode(true);", without success.

any ideas?


  • Thanks for the report. This pointed out a couple of issues. First, we'd not configured nightly.enyojs.com to allow CORS requests of the JSON files for g11n support. That's fixed now.

    Second, it looks like a setting of use24HrsMode in the TimePicker spec is always being overridden. This is a bug introduced when I merged in code that provided a default setting for TimePicker when the g11n library wasn't loaded. I'll commit a fix today.
  • > First, we'd not configured nightly.enyojs.com to allow CORS requests of the JSON files for g11n support. That's fixed now.

    Thanks - Ben !!! I have been waiting for this fix for weeks. :)
    (I tried this several times a day since then.)
    I confirm this configuration change works ok for me now. :)

    This is related to the issue I reported in https://enyojs.atlassian.net/browse/ENYO-1371
    (There might be more issues hidden as pointed out in that bug report.)
  • Yeah, I fixed the main server, but forgot to propogate the .htaccess file changes to the subdomains.
  • Ah - ok. Thanks again for fixing this issue. Now I can fiddle around with my code.
  • Thanks, I found a new bug in the TimePicker. If you open the sampler-App an then choose onyx/TimePicker. Open the hour field of the 24h picker. Afther then chose the Button "View Source" at bottom right. Next close the source view and chose the hour field of the 24h picker. The bug is, you can ony choose 0-4 items. I have the same bug in my App, can you fix this?
  • Ooh, that's a nasty one. I've filed https://enyojs.atlassian.net/browse/ENYO-2929 for it. I just verified the bug is in both the 2.2 and nightly version of sampler.
  • OK, starting to look at this. Seems like a version of the popup problems we've occasionally had. Doing the view source causes the content area to re-render, which disassociates the existing popup scroller from the picker. Checking into root cause now.
  • I can't find a working solution. Only the hour field is failed, the minutes works fine.
  • Ah, I've got a change pending for Enyo to fix the whole floating layer system, but I've not submitted it yet. If you want to try it, see the changes at the top of https://github.com/enyojs/enyo/tree/body-wrapper-div
  • Thanks for your answer. I have replace the the enyo folder with the branch 'body-wrapper-div" in my project. The result is the same, the TimePicker is not working, if I change the view.
  • I have remove the render() - Method in the view of my project, after then works the picker fine.
  • OK, we'll have to poke at this more. There's a reason that branch hasn't been merged yet.
Sign In or Register to comment.