I can't load Ares 2 local

edited April 2012 in Ares
I've downloaded the last version at github and it doesn't work for me at local. Can anyone upload it to a website or tell me how i can run it?

greetings

Comments

  • edited April 2012
    Can you confirm that you have set up the directory correctly? I placed the Ares dir (I called it Ares-Project) alongside the enyo dir so that they are all on the same level (so it is not inside libs or any other folder).

    image

    If you have a look at package.js inside Ares, then you should see the following which described the folder structure if my description isn't clear:

    enyo.depends(
    "$lib/layout",
    "$lib/onyx",
    //
    "$lib/extra/analyzer",
    "../phobos/source",
    //
    "../deimos/source",
    "../deimos/resources",
    //
    "../lib/layout-panels",
    "../lib/localStorage",
    "../lib/tree",
    "../lib/service",
    "../harmonia/source"
    );

    Hope that helps.
  • It did not run for me as well when I first downloaded it as the link to the lastest enyo was still b3, I put b4 in place and it loads fine.

    That said it appears the dream of using ares for anything what so ever right now is still a dream, it appears to do nothing ares like what so ever. I think it can load dropbox, and that about ends what it is capable of, unless I loaded something completely wrong Ares is unusable.

    Can anyone else confirm that Ares does nothing at the moment that resembles Ares 1
  • edited April 2012
    Hi Isandunk, I've the directory like that:
    - Ares-Project/
       - ares/
          - index.html
          - package.js
       - deimos/
       - harmonia/ 
       - lib/
          - foss/
          - layout-panels/
          - localStorage/
          - service/
          - tree/
       - node/
       - phobos/
       - php/
    - enyo-2.0b4/
       - examples/
       - source/
       - tools/
       - enyo.js
       - loader.js
       - package.json
    - lib/
       - layout/
       - onyx/
       - fu/
       - extra/
    - enyo/ (enyo 1.0 git repository)
      - framework/
      - support/
    When I try to run Ares-Project/ares/index.html I only view a gray background. Why?

    Thanks
  • I just added some brief setup instructions to the ares-project readme. Essentially, you just need ares-project sitting next to the latest versions of enyo and lib (/onyx, /layout, and /extra), and point your browser to ares-project/ares/index.html. Sorry for the confusion.

    Please have a read through the Ares readme which describes exactly what you can test drive right now, and what is coming up: https://github.com/enyojs/ares-project

    Although Ares right now is not ready for app development (particularly the Enyo 2 UI designer is still in progress), it is far enough along that we are opening the repository so that early-adopters can follow along with our development and provide feedback as we move it forward.
  • @adrianmugnoz: ares-project depends on the debug version of Enyo 2 (not the built version). So you'll want to remove/rename your "enyo" (enyo 1.0) folder and add the latest Enyo 2 "enyo" folder from github or the 2.0b4 release ZIP in that same location.
  • Thanks Kevin, that's great.
  • edited May 2012
    @adrianmugnoz: I get the same problem when trying to use Ares2 localy in FF.
    Firebug throws this error:
    Security error
    file:~/Development/Enyo/Framework/ares-project/lib/localStorage/LocalStorage.js
    Line 12
    In Chromium it works, sort of. I get three columns of equal width where the most right is the editor, but on a netbook display (1024x600) that column is simply to small to use.

    All on Debian Testing/Unstable Gnu/Linux.
  • You should check that you have dom.storage.enabled set to 'true' in config.

    I remember having this problem a long time ago, a quick google dragged this up too: http://meyerweb.com/eric/thoughts/2012/04/25/firefox-failing-localstorage/

    Hope it helps.
  • dom.storage.enabled was true.

    In the article you linked it talked about the cookie settings (Keep until: “ask me every time”). I changed that setting to "Delete on browser exit" and now it 'works' in the same way as it does on Chrome.

    Thanks for the link, had the same problem on another site as well.
  • Weird, there are a number of bugs filed on Mozilla's tracker at different intervals over the last few years about the on-again-off-again support that localStorage has. Hopefully this will improve in future builds and all this Security Error nonsense will stop ...
  • In a way it makes sense. Compare it with cookies, its offline data storage that can be used to track you (like cookies). If it is always available to websites than that could create a nice way to still track a user even if (s)he has disabled cookies. Sort of like Flashcookies.

    What would be usefull is an extra setting for localstorage and a userfriendly tool to browse/edit the localstorage. Preferably build into the browser itself.
  • In Chrome you can just type localStorage into the console and browse the object in a drop-down list. Sadly I don't think Firefox has this capability but hopefully it will in the future.

    I agree it makes sense to have cookie-like security with a working implementation,but I guess that is what dom.storage.enabled and dom.storage.default_quota are intended for in the config.
  • Looks like inspecting localStorage also works in Firebug in Firefox 13 beta.
  • edited May 2012
    @quindo: note that you can drag the entire interface left and right. Iow, you should be able to reveal more of the editor by pullling it to the left.

    Also, the Chrome inspector shows localStorage data in the Resources tab.
  • I prefer FF to chromium , I'm just too used to FireBug :-)

    @unwiredben, Cool, I'll have to look at installing FF beta on debian :-)

    @sjmiles, Thanks, I had already tried that but it didn't work. probably did something wrong because it works now.
  • Thanks for your help. This fixed my Ares problem. I look forward to using this when it is fully developed.
  • BTW - no hurry - but can we expect some update to www.openwebosproject.org in respect to Ares2?
    The overview page talks about: "April: Ares 2.0, Enyo 2.1, Node services"
    Ares2 is considered as being part of Open webOS - right ?
  • When that roadmap was originally put together back in January, we weren't quite sure how things would play out. Enyo is a sister project to Open webOS -- we're used for the system, but our goal is to support lots of mobile and desktop web application environments.

    I'm not sure when we'll see a recalibaration of that roadmap; we did start the Ares 2.0 public release in April, but we're not yet making specific announcements about when new features will be released.
  • It is unusable in it's current state, or did I miss something, if I load the index in deimos dir it loads something a little ares like but pretty much useless at the moment.

    Guess I was expecting something as useful as the beta of ares 1 was.
  • Nope, we're not there yet. We've been focusing on the xplat features of Enyo & its supporting libraries, since they're needed more. However, I expect that Ares 2 will mature fairly quickly once we're able to "lock up" the completely Enyo 2 & Onyx feature set.
  • I've been working on fixing some of the broken bits in Ares 2. We should have a version that shows more of how things are supposed to work very soon (next couple of days). There's still quite a bit of work to do, of course, but this should give you more of an idea of how the pieces are supposed to fit together.
  • edited June 2012
    We need Ares 2. Please!
Sign In or Register to comment.