Enyo and webpack

I'm trying to bundle Enyo 2.7 in a webpack-enabled project. Unfortunately it seems that Enyo 2.7 uses it's own in-browser CommonJS-like require() implementation, making it pretty much incompatible with module bundlers like webpack.

It would be really helpful if the Enyo team or alike would comment on how this might be solved, as webpack really is somewhat de facto these days :-)

Thanks.

Comments

  • Hi! Enyo 2.7's module system was designed to meet some very specific requirements that we were not able to meet with webpack at the time we began that work. It might be possible to work around the issue but we have no plans to update Enyo 2.7's module system to be compatible with webpack. We tried to keep the interface as compliant as possible with the CommonJS spec.
Sign In or Register to comment.