Problem installing 2.7

I'm trying to install 2.7 and 1.0 of the dev tools, but when I run

npm install -g enyo-dev

I'm getting version 0.5.2 and not version 1.0.0, how do I get the correct version?

Comments

  • I had this too! I was also getting '2.6.0-dev' modules instead of 2.7.

    BTW, i'm still playing with it all, so what I did may not be the right way..

    I managed to get enyo-dev 1.0.0 by using git, the details should be here:
    https://github.com/enyojs/enyo-dev#setup-manual
    just look for the manual install section.

    Regarding 2.7 over 2.6.0-dev, once I had init'd my project I edited '.enyoconfig' in the root changing all 2.6.0-dev entries under 'targets' to read '2.7'. I then re-ran init to pull in the newer versions. I also took the opportunity to remove those modules that I didn't want.

    Hope this all helps! Good luck!
  • edited April 2016
    NPM hasn't been updated yet and we're tracking that down now. Regarding the targets, 2.6.0-dev is our current 'master' branch for many of the repos. The naming is a bit misleading but as of today that will get you the bleeding edge version. If you want the latest stable release, you can use the 2.7.0 tag instead.
      "targets": {
        "enyo": "2.7.0"
      }
    
  • Apologies for the technical issues regarding the 1.0.0 publishing to npm. Everything has been sorted out and 1.0.0 is now live on npm for install :)
  • edited April 2016
    Coming back after a few weeks away... I npm uninstalled my old manual enyo-dev installation and manually deleted old .enyo folder. There are 2 different npm commands shown for installing:
    npm install -g enyo-dev from https://github.com/enyojs/enyo-dev#setup-npm
    or
    npm install -g enyo dev from http://forums.enyojs.com/discussion/2451/enyo-2-7-0-released

    I think I tried the enyo dev version and got `node-gyp rebuild` errors, so then I tried to clean everything up and ran my current enyo-dev install without error.

    The problem is that enyo init is not initializing any libs...

    enyo init MyNewProject gives:
    cloning enyo and checking out 2.7.0
    16:45:17.498Z WARN enyo-dev/init: Failed to initialize library "enyo"

    enyo init MyNewProject3 -t onyx-app gives:
    cloning enyo and checking out 2.7.0
    cloning onyx and checking out 2.7.0
    cloning layout and checking out 2.7.0
    cloning enyo-ilib and checking out 2.7.0
    16:49:59.041Z WARN enyo-dev/init: Failed to initialize library "enyo"
    16:49:59.041Z WARN enyo-dev/init: Failed to initialize library "onyx"
    16:49:59.041Z WARN enyo-dev/init: Failed to initialize library "layout"
    16:49:59.041Z WARN enyo-dev/init: Failed to initialize library "enyo-ilib"


    I'm on Win7/32 running node v5.7.0, npm v3.6.0 I have network connectivity

    -Any tips for clean install, known issues, etc?

    EDIT: My bad!
    - I forgot that I use my git bash for enyo commands, NOT Windows CMD

    I'm still curious if there is supposed to be a difference between enyo dev and enyo-dev when installing, but my libraries are now initializing when I use git bash after installing using enyo-dev
    - apologies for the non-issue.
  • Should be enyo-dev. Running npm install -g enyo dev will try to install 2 packages -- enyo and dev.

    cc: @RoySutton
  • Thanks @theryanjduffy - That makes total sense - the command on the release announcement post tries to install a deprecated, linux-only package: https://github.com/iliakan/node-dev/
    I appreciate the response!
  • I'm having issues too. I reinstalled node (5.11) and installed pug as i got a warning when installing enyo-dev with npm about jade being depreciated...
    nut when I try to create a project I get an error:

    >enyo init test-proj
    cloning enyo and checking out 2.7.0
    19:56:12.625Z WARN enyo-dev/init: Failed to initialize library "enyo"

    I'm on windows 7 64
  • Hi Fergus, You seem to be having the same init errors I was getting when I forgot I needed to issue those commands from my GIT BASH rather than Windows CMD. Are you using a GIT-friendly terminal?
  • Did not know that. I installed git....seemed to work. Thanks much!
  • I'm getting that issue again: Failed to initialize library "enyo" again. I'm using Git Bash which used to work but that was a year ago. Is there an issue with newer Node versions?
  • Hey @fergus44 I think I had to rollback on Windows at some point. What I have currently is Node: v6.7.0 and NPM: 3.10.3. I'm not sure what the latest working versions are, but that pairing seems to work.
  • Thanks. Will try.

  • edited March 3

    Nope! Still not working. Did a complete uninstall and reinstall of node and npm. node version: 6.7.0, NPM version 3.10.3.

    Get this on init:

    $ enyo init --template=onyx-app LawTools2.7

    cloning enyo and checking out 2.7.0

    cloning onyx and checking out 2.7.0

    cloning layout and checking out 2.7.0

    cloning enyo-ilib and checking out 2.7.0

    20:13:14.109Z WARN enyo-dev/init: Failed to initialize library "enyo"

    20:13:14.109Z WARN enyo-dev/init: Failed to initialize library "onyx"

    20:13:14.109Z WARN enyo-dev/init: Failed to initialize library "layout"

    20:13:14.109Z WARN enyo-dev/init: Failed to initialize library "enyo-ilib"

    I see a lot of errors and warnings when installing enyo-dev. Depreciated dependencies. Should I try to manually install the suggested replacements or do the enyo-dev scripts need them specifically?

    Using windows 10 64 BTW...

    the warnings:

    npm WARN deprecated [email protected]: Package no longer supported. Contact [email protected] for more info.

    npm WARN deprecated [email protected]: � Thanks for using Babel: we recommend using babel-preset-env now: please read babeljs.io/env to update!

    npm WARN deprecated [email protected]: Jade has been renamed to pug, please install the latest version of pug instead of jade

    npm WARN deprecated [email protected]: Deprecated, use jstransformer

    npm WARN deprecated [email protected]: Please update to at least constantinople 3.1.1

    npm WARN deprecated [email protected]: This version is no longer maintained. Please upgrade to the latest version.

    npm WARN deprecated [email protected]: This version is no longer maintained. Please upgrade to the latest version.

    npm WARN deprecated [email protected]: This version is no longer maintained. Please upgrade to the latest version.

    npm WARN optional Skipping failed optional dependency /enyo-dev/chokidar/fsevents:

    npm WARN notsup Not compatible with your operating system or architecture: [email protected]

Sign In or Register to comment.