Issues with Deployment

edited April 2013 in Packaging Apps
I'm trying to deploy an application that I'm building and I keep getting an error
<br />TypeError: Object function Walker(root) {<br />  if (!(this instanceof Walker)) return new Walker(root)<br />  EventEmitter.call(this)<br />  this._pending = 0<br />  this._filterDir = function() { return true }<br />  this.go(root)<br />} has no method 'init'<br />    at Object.<anonymous> (c:\projects\ph-forecasting-web\src\main\webapp\enyo\tools\minifier\minify.js:229:8)<br />    at Module._compile (module.js:456:26)<br />    at Object.Module._extensions..js (module.js:474:10)<br />    at Module.load (module.js:356:32)<br />    at Function.Module._load (module.js:312:12)<br />    at Function.Module.runMain (module.js:497:10)<br />    at startup (node.js:119:16)<br />    at node.js:901:3<br /><br />    at run (c:\projects\ph-forecasting-web\src\main\webapp\enyo\tools\deploy.js:154:9)<br />    at Object.<anonymous> (c:\projects\ph-forecasting-web\src\main\webapp\enyo\tools\deploy.js:168:1)<br />    at Module._compile (module.js:456:26)<br />    at Object.Module._extensions..js (module.js:474:10)<br />    at Module.load (module.js:356:32)<br />    at Function.Module._load (module.js:312:12)<br />    at Function.Module.runMain (module.js:497:10)<br />    at startup (node.js:119:16)<br />    at node.js:901:3<br />
I'm using the last version of node (0.10.3) and walker though maybe it's not the correct package.

If anyone has any ideas I would really appreciate it.

Comments

  • Have you tried with the most recent 0.8.x release of node? I don't think we've tested yet with 0.10.
  • I tried with 0.8.9 and I'm having the same problem. A coworker tried and he able to run the deploy script successfully with 0.10.1 on the same code base.
  • edited April 2013
    I don't think you're supposed to install a npm walker package... that's just referring to the walker.js file that comes (annoyingly) in the enyo/tools/minifier/node_modules folder. If you're using the wrong file, that would explain the errors.

    We've just updated the uglify-js and less versions in our master tree for the next release, but we don't recommend doing your own npm updates for those.

    If you need to get a fresh copy of that file, see https://raw.github.com/enyojs/enyo/master/samples/DrawerSample.html
Sign In or Register to comment.