Enyo Sampler - problem running it locally

Hi,

I've been trying to get the Enyo Sampler running on my local machine. I used the one on Github as a starting point (https://github.com/enyojs/sampler), adding to it as I saw fit (i.e. adding the samples etc). I can scroll through the navigation list fine (disabled web security on Chrome for it to pick up the manifest.json file), but once I select an item that is supposed to render on a page, I always get the same error:

example:

no constructor found for kind "enyo.sample.PlatformSample".

I've looked at my package.js file (in /source) and it looks okay, i.e. I tried the following:
enyo.depends(
	"$lib/layout",
	"$lib/onyx",
	"$lib/g11n",
	"$lib/g11n/source/css/",	
	"$lib/g11n/source/name",
	"$lib/g11n/source/phone",				
	"$lib/layout/fittable/samples",
	"$lib/layout/panels/samples",
	"$lib/layout/list/samples",
	"$lib/layout/tree",
	"$lib/layout/tree/samples",
	"$lib/layout/imageview",
	"$lib/layout/imageview/samples",
	"$lib/onyx/samples",
	"$lib/canvas",
	"$lib/canvas/samples",	
	"$enyo/samples",
	"$lib/g11n/samples",	
	"App.css",
	"App.js"
);
Perhaps I'm missing something fundamental here - can anyone help? Or is there a full version of the sampler available for download somewhere?

Thanks,

Frank.

Comments

  • I personally can run the sampler as-is cloned from the sampler repo in Chrome (with those disable switches) and Firefox. Have you tried it without any local modifications to see if that works? Make sure you also pull in all the submodules.

    Do you see any other messages in the console log? What about the debugger in Chrome? Are all the source files loaded?
  • Thanks mate - I'll try what you suggested and see. I'm taking a slightly different approach in what I'm doing now so I'm not sure if getting the Sampler running locally is absolutely required for the moment.

    Much appreciate the response - thanks!
Sign In or Register to comment.